Excel VBA教程:FormulaLocal属性

返回或设置指定对象的公式,用用户语言中 A1-样式引用。对于 Range对象,为 Variant 类型;对于 Series对象,为 String 类型,可读写。

说明

如果指定单元格包含常量,则本属性返回的就是该常量。如果该单元格为空,则本属性将返回一个空字符串。如果该单元格包含公式,本属性将把该公式作为字符串返回,格式与该公式在编辑栏中的显示格式相同(包括等号)。

如果将单元格的值或公式设为日期类型,则 Microsoft Excel 将检查该单元格的格式是否符合某个日期或时间数组格式,如果不符合,将采用默认的短日期数字格式。

如果指定区域是一维或二维区域,则可将公式指定为 Visual Basic 中相同维数的数组。同样,也可在 Visual Basic 数组中使用公式。

对多重单元格区域设置公式,则该区域中所有单元格都用此公式填充。

Excel VBA教程:FormulaLocal属性·示例

假定使用的是美国英语版 Microsoft Excel,并往第一张工作表的 A11 单元格中输入了公式“=SUM(A1:A10)”。如果在一台运行德文版 Microsoft Excel 的计算机上打开该工作表,并运行下例,该示例将在消息框中显示公式“=SUMME(A1:A10)”。


MsgBox Worksheets(1).Range(A11).FormulaLocal

上页:Excel VBA教程:FormulaLabel属性 下页:Excel VBA教程:FormulaR1C1属性

Excel VBA教程:FormulaLocal属性

Excel VBA教程:FormulaR1C1属性 Excel VBA教程:FormulaR1C1Local属性
Excel VBA教程:Forward属性 Excel VBA教程:FreezePanes属性
Excel VBA教程:FullName属性 Excel VBA教程:FullNameURLEncoded属性
Excel VBA教程:Function属性 Excel VBA教程:Gap属性
Excel VBA教程:GapDepth属性 Excel VBA教程:GapWidth属性
Excel VBA教程:GenerateGetPivotData属性 Excel VBA教程:GermanPostReform属性
Excel VBA教程:GradientColorType属性 Excel VBA教程:GradientDegree属性
Excel VBA教程:GradientStyle属性 Excel VBA教程:GradientVariant属性
Excel VBA教程:GrandTotalName属性 Excel VBA教程:GridlineColor属性
Excel VBA教程:GridlineColorIndex属性 Excel VBA教程:GroupItems属性
版权所有 © 中山市飞娥软件工作室 证书:粤ICP备09170368号